DISTCLEANFILES=config/stamp1 config/stamp2
# Some files/directories generated during check that should be cleaned
CHECK_CLEANFILES+=*-tmp
# Define rules for lib, progs, check, and tests.
# These simply involve recursing into subdirectories.
test _test: check
lib progs check-p check-s:
    @@SETX@; for d in $(SUBDIRS); do                                \
    for d in $(SUBDIRS); do                                \
      if test $$d != .; then                                        \
       (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;            \
      fi;                                                           \
    done
# Make all, tests, and (un)install
tests:
    @@SETX@; for d in $(SUBDIRS); do                        \
    for d in $(SUBDIRS); do                        \
      if test $$d != .; then                                        \
       (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;            \
      fi;                                                           \
      done
# Check-clean also recurses into examples directory
check-clean:
    @@SETX@; for d in $(SUBDIRS) examples; do               \
    for d in $(SUBDIRS) examples; do               \
      if test $$d != .; then                                        \
       (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;            \
      fi;                                                           \
    done
    $(RM) -rf prefix-tmp destdir-tmp
# Some C++ compilers/linkers will create a directory named ii_files in
# the root directory, which should be cleaned.
mostlyclean-local:
    if test -d ii_files; then                                       \
uninstall: uninstall-recursive uninstall-examples 
# 'make install-all' also installs examples
install-all:
    @$(MAKE) $(AM_MAKEFLAGS) install
uninstall-all:
    @$(MAKE) $(AM_MAKEFLAGS) uninstall
# Install examples in this directory and recursively
install-examples uninstall-examples:
    @@SETX@; for d in examples $(HDF5_INTERFACES) $(HL); do               \
    for d in examples $(HDF5_INTERFACES) $(HL); do               \
        (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;           \
    done
# Placeholder to remind users that docs are now in a separate repository.
install-doc:
    @echo "docs no longer live in this tree.  Use install-examples to install examples."
uninstall-doc:
    @echo "docs no longer live in this tree.  Use install-examples to install examples."
    -diff -r destdir-tmp${prefix} ${prefix}
# Only source files in the src directory include tracing information,
# so 'make trace' only needs to recurse into that directory.
trace:
    @(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
# Run tests with different Virtual File Drivers.
# Currently, only invoke check-vfd in the test directory.
check-vfd:
    @@SETX@; for d in src test; do                                 \
    for d in src test; do                                 \
      if test $$d != .; then                                       \
        (cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;          \
      fi;                                                          \
    done
# Automake wants to make config.status depend on configure.  This
# makes sense, but config.status can't always be regenerated
# properly, which can cause builds to fail.
# This is a problem for our Daily Tests, which need to be able to
# 'make distclean' reliably before running configure.