Source
80
80
DISTCLEANFILES=config/stamp1 config/stamp2
81
81
82
82
# Some files/directories generated during check that should be cleaned
83
83
CHECK_CLEANFILES+=*-tmp
84
84
85
85
# Define rules for lib, progs, check, and tests.
86
86
# These simply involve recursing into subdirectories.
87
87
test _test: check
88
88
89
89
lib progs check-p check-s:
90
-
@@SETX@; for d in $(SUBDIRS); do \
90
+
for d in $(SUBDIRS); do \
91
91
if test $$d != .; then \
92
92
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
93
93
fi; \
94
94
done
95
95
96
96
# Make all, tests, and (un)install
97
97
tests:
98
-
@@SETX@; for d in $(SUBDIRS); do \
98
+
for d in $(SUBDIRS); do \
99
99
if test $$d != .; then \
100
100
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
101
101
fi; \
102
102
done
103
103
104
104
# Check-clean also recurses into examples directory
105
105
check-clean:
106
-
@@SETX@; for d in $(SUBDIRS) examples; do \
106
+
for d in $(SUBDIRS) examples; do \
107
107
if test $$d != .; then \
108
108
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
109
109
fi; \
110
110
done
111
111
$(RM) -rf prefix-tmp destdir-tmp
112
112
113
113
# Some C++ compilers/linkers will create a directory named ii_files in
114
114
# the root directory, which should be cleaned.
115
115
mostlyclean-local:
116
116
if test -d ii_files; then \
123
123
uninstall: uninstall-recursive uninstall-examples
124
124
125
125
# 'make install-all' also installs examples
126
126
install-all:
127
127
@$(MAKE) $(AM_MAKEFLAGS) install
128
128
uninstall-all:
129
129
@$(MAKE) $(AM_MAKEFLAGS) uninstall
130
130
131
131
# Install examples in this directory and recursively
132
132
install-examples uninstall-examples:
133
-
@@SETX@; for d in examples $(HDF5_INTERFACES) $(HL); do \
133
+
for d in examples $(HDF5_INTERFACES) $(HL); do \
134
134
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
135
135
done
136
136
137
137
# Placeholder to remind users that docs are now in a separate repository.
138
138
install-doc:
139
139
@echo "docs no longer live in this tree. Use install-examples to install examples."
140
140
141
141
uninstall-doc:
142
142
@echo "docs no longer live in this tree. Use install-examples to install examples."
143
143
170
170
-diff -r destdir-tmp${prefix} ${prefix}
171
171
172
172
# Only source files in the src directory include tracing information,
173
173
# so 'make trace' only needs to recurse into that directory.
174
174
trace:
175
175
@(cd src && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
176
176
177
177
# Run tests with different Virtual File Drivers.
178
178
# Currently, only invoke check-vfd in the test directory.
179
179
check-vfd:
180
-
@@SETX@; for d in src test; do \
180
+
for d in src test; do \
181
181
if test $$d != .; then \
182
182
(cd $$d && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1; \
183
183
fi; \
184
184
done
185
185
186
186
# Automake wants to make config.status depend on configure. This
187
187
# makes sense, but config.status can't always be regenerated
188
188
# properly, which can cause builds to fail.
189
189
# This is a problem for our Daily Tests, which need to be able to
190
190
# 'make distclean' reliably before running configure.